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Lab 04:  Basic MasterCAM & CNC Milling Operations
I.  Purpose
A.) Provide an introduction to the MasterCAM for SolidWorks software
B.) Provide experience using the laboratory’s CNC Mill in automated operation
II. Practice

Your lab team will work together to produce and program the milling operations, then each person will produce a part at the milling workstation in CNC mode.  The lab instructor will lead your group through this exercise, but class participation is expected.  You are to document the process in your engineering notes, as necessary, for later production of your project files.

MasterCAM for SolidWorks Process Planning & CNC Programming Operations:  

A.) Log into the Manufacturing Engineering Laboratory computers containing MasterCAM.

a. User Name:  
.\mfg_e_lab
b. Password:
mfgelab
B.) Open the SolidWorks software by double-clicking the shortcut icon in the bottom, right corner of the screen.

C.) Observe and take notes as the lab instructor explains the computer display and operation of the mill.  The lab instructor will help you to follow the process and watch for hazards.  Your team members should also do the same.

D.) Open the Clock Front file the DeskTop

a. File > Open > DeskTop > Clock Front
E.) Save the Clock Front file to your team’s folder with your initial and last name appended.

a. File > Save As 
b. Click on Desktop

c. Click on your team folder

d. Append your first initial and last name to the file name

e. Save
F.) Start your MasterCAM work by clicking on the MasterCAM 2018 tab below the top toolbars (and on the right side)
Set Up The Work Coordinate System & Tooling Plane
a. Click on the Plane Manager (top toolbars – left side)

b. Click the check box for the T plane follows WCS

c. Select the proper plane for the top of the workpiece by clicking on the appropriate  plane for the WCS and observing the axes attached to the workpiece onscreen.

d. Click the green check button.

Set Up The Machine Group Properties For The Part
e. Click on the red & white M tab at the top of the feature tree window (left side)

f. Click on the Properties expander box

g. Click on Files under the Properties tree

h. On the Machine Group Properties window that  pops up, under the Files tab and in the Machine – Toolpath Copy box, click on the Replace button 

i. On the pop-up window Open Machine Definition File, 

i. click on MILL DEFAULT MM

ii. click on the OPEN button.  (This selects the post-processor closest to our mill.)

j. On the Machine Group Properties window, in the Tool Library box, click on the Open Folder button 

k. On the pop-up window Select Tool Library File, 

i. click on CIM_LAB option

ii. click on the OPEN button.  (This selects the tool library for our mill.)

l. At the top of the Machine Group Properties window, click on the Tool Settings tab
m. In the Material box, click on the Select button , and on the pop-up window Material List,
i. click on the fly-out for Source

ii. click on the Mill-library option

iii. scroll down until you see the material closest to what you want to mill (in this case, WOOD inch) and highlight it

iv. click on the green check button.  (This tells the computer to use this material and the tool to compute cutting parameters for each operation.)

n. At the top of the Machine Group Properties window, click on the Stock Setup tab
o. In the Stock Plane box, click on the table button , and on the pop-up window Plane Selection,

i. Select the proper plane for the top of the workpiece by clicking on the appropriate  plane for the WCS and observing the axes attached to the workpiece onscreen (as before)

ii. Click the green check button.

p. Back in the middle of the Machine Group Properties window, under  Stock Setup tab
i. click on the button for Display
ii. click on the button for Solid
iii. move your mouse over the top, left, front corner of the red stock rectangle and click on it to identify the touch-off for our soft/part home (origin)
iv. click on each of the yellow dimension boxes in the red, stock display window and enter the stock dimensions.  In this case:

1. Y dimension for the clock front is 5.45

2. X dimension for the clock front is 4.45

3. Z dimension for the clock front is 0.75

v. click on the green check button
vi. verify that the clock front workpiece is just enclosed by the red tinted rectangle.  (This represents the stock for our operations.)

q. Back on the SolidWorks top toolbar:

i. click on the tab for File

ii. click on the Save option on the pop-up menu.
r. In the SolidWorks window, right click on the face of the clock, and select the Normal To button in the menu that pops up

The process planning for each operation takes place in the planning tree window (left side) under the Toolpath Group heading.  The icons and buttons that are most used are:

1. Insertion Point – this is the red, right-pointing triangle under the Toolpath Group

2. Verify Button – this is the gold-colored block with a white clipboard and check-box button near the middle, right at the top of the planning tree window

3. Backplot Button – this is the button with three light colored contours on a dark blue background near the middle, right at the top of the planning tree window
4. Post (G-Code) Button – this is the button with the G1 symbol near the middle, right at the top of the planning tree window
Follow the steps (below) to produce the process plan for your product:

A. In the SolidWorks window, right click on the face of the clock, and select the Normal To button in the menu that pops up
Mill the Contours of the Corners of the Clock Face

A.) Right click on the box to the right of the Insertion Point > Mill Paths > Contour
B.) The Chain Manager window pops up.  
a. Use your mouse to select the arc at the top, right corner of the clock face, clicking near the top edge of the curve
b. Click the green check button

C.) The 2-D Toolpaths – Contour window pops up on the screen.  In the tree on the left of this window, click on Tool
a. Click on the Select Library Tool button

b. Select tool
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c. Click on the green check button.  This will select the tool and calculate the correct cutting parameters for the material and tool selection.

D.) In the tree in the 2-D Toolpaths – Contour window, click on Cut Parameters
a. In the window, verify the Compensation Direction, and change as necessary – the goal is to cut just the right hand corner (avoiding the left fixed fence on the milling table fixture)

b. In the tree below Cut Parameters, click on Lead-In/Out, and uncheck the button for Lead-In/Out.  Using a lead-in or lead-out arc on this part will take us beyond the work envelope of the mill.
E.) In the tree in the 2-D Toolpaths – Contour window, click on Linking Parameters
a. In the yellow box next to Depth, set the depth of cut as necessary, remembering that it should be a negative value.  (In this case, the depth should be – 0.45)

b. Click on the green check button – that is all for this operation.

F.) Click on the Verify button while this operation is highlighted.  Position the verify window that pops up, and:

a. On the Home tab, click on the Tool Components fly-out button and uncheck Holder.

b. Click on the View Tab and click on the Isometric button
c. In the simulation window, adjust the slider for speed to about 1/4 and

d. Click on the Play triangle and watch the operation.

e. Follow your instructor’s directions to make sure the operation is correct.

G.) Minimize the verify window and return to the operations tree on the far left side.

H.) Copy Operations:  Highlight the 1st  operation, then right click on it and select Copy
I.) Right click on the box to the right of the insertion point  and select Paste
J.) In the newly copied operation, click on the Parameters icon.

K.) In the tree in the 2-D Toolpaths – Contour window, click on Linking Parameters
a. In the yellow box next to Depth, set the depth of cut as necessary, remembering that it should be a negative value.  (In this case, the depth should be – 0.75)

b. Click on the green check button – that is all for this operation.

L.) Return to the operations tree on the far left side, and click on the Backplot button:

a. A message box opens with Warning-Dirty Operations Selected: click on the green check button
b. The Backplot window opens:  click on the green check button 

M.) On the operations tree, highlight the Toolpath Group, then …

N.) Click on the Verify button while that is highlighted.  Position the verify window that pops up, and:

a. Click on the View Tab and click on the Isometric button
b. In the simulation window, adjust the slider for speed to about 1/4 and

c. Click on the Play triangle and verify the operation removes the remaining corner material.

d. Follow your instructor’s directions if the operation is not correct.

O.) Minimize the verify window and return to the operations tree on the far left side.
P.) Return to the SolidWorks top toolbar, and click File > Save.
Mill the Pockets of the Lettering/Numbering of the Clock Face
A.) Right click on the box to the right of the Insertion Point > Mill Paths > Pocket
B.) The Chain Manager window pops up.  

a. Use your mouse to select the middle of the S, the M (not the hole), and the D of the clock face

b. Click the green check button

C.) The 2-D Toolpaths – Pocket window pops up on the screen.  In the tree on the left of this window, click on Tool
a. Click on the Select Library Tool button

b. Select tool
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c. Click on the green check button.  This will select the tool and calculate the correct cutting parameters for the material and tool selection.

D.) In the tree in the 2-D Toolpaths – Contour window, click on Cut Parameters
a. In the window, make sure the box for Stock to leave on walls is set to 0.0
b. Also in the window, make sure the box for Stock to leave on floors is set to 0.0
c. In the tree below Cut Parameters, click on Roughing, and choose a pattern for Cutting Method.  
d. In the tree below Roughing, click on Entry Motion, and choose the button for Off.  We will be using a center-cutting end mill, and the pockets are shallow, so we can save time by plunging directly into the pockets.
e. In the tree below Cut Parameters, click on Finishing, and uncheck the box for Finish.  We will use a smaller diameter tool to finish the corners of these letters, later on. (It is hard to make a square corner with a round tool of large diameter – but we can fake it!)
E.) In the tree in the 2-D Toolpaths – Pocket window, click on Linking Parameters
a. In the yellow box next to Depth, set the depth of cut as necessary, remembering that it should be a negative value.  (In this case, the depth should be – 0.05)

b. Click on the green check button – that is all for this operation.

F.) Click on the Verify button while this operation is highlighted.  Position the verify window that pops up, and:

a. In this simulation , we will view the operation from the top view 

b. Click on the Play triangle and watch the operation.

c. Follow your instructor’s directions to make sure the operation is correct.

G.) Minimize the verify window and return to the operations tree on the far left side.

H.) Copy Operation:  Highlight the current (3rd) operation, then right click on it and select Copy
I.) Right click on the box to the right of the insertion point  and select Paste
J.) In the newly copied operation, click on the Parameters icon.

K.) The 2-D Toolpaths – Pocket window pops up on the screen.  In the tree on the left of this window, click on Tool
a. Click on the Select Library Tool button

b. Select tool
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c. Click on the green check button.  This will select the tool and calculate the correct cutting parameters for the material and tool selection.

d. In the tree below Cut Parameters, click on Roughing, and uncheck the box for  Rough.  
e. In the tree below Cut Parameters, click on Finishing, and check the box for Finish.  This is the smaller diameter tool we will use to finish the edges and corners of the SMD letters

f. In the tree below Finishing, click on Lead In/Out, and uncheck the box for Lead In/Out.  We might have enough room for lead in and lead out within the pockets, but it would be a very small improvement in finish relative to the extra time.
L.) In the tree in the 2-D Toolpaths – Pocket window, click on Linking Parameters
a. In the yellow box next to Depth, verify the depth of cut as necessary, remembering that it should be a negative value.  (In this case, the depth should be – 0.05)

b. Click on the green check button – that is all for this operation.

M.) Return to the operations tree on the far left side, and click on the Backplot button:

a. A message box opens with Warning-Dirty Operations Selected: click on the green check button

b. The Backplot window opens:  click on the green check button 

N.) Return to the planning tree window and right click on the box to the right of the Insertion Point > Mill Paths > Pocket
O.) The Chain Manager window pops up, like before.  

a. Being careful not to accidently pick an edge, use your mouse to select the middle of the numeric digits 1, 6, and 12 on the clock face. Note that the order that you mill these pockets will affect your operations timing. (You can change this later.)
b. Click the green check button

P.) The 2-D Toolpaths – Pocket window pops up on the screen.  In the tree on the left of this window, click on Tool
a. Highlight  tool
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b. Click on the green check button.  This will select the tool and calculate the correct cutting parameters for the material and tool selection.

Q.) In the tree in the 2-D Toolpaths – Contour window, click on Cut Parameters
a. In the window, make sure the box for Stock to leave on walls is set to 0.0
b. Also in the window, make sure the box for Stock to leave on floors is set to 0.0
c. In the tree below Cut Parameters, and click on Roughing 
d. Check the box for Rough, and choose a pattern for Cutting Method.  
e. In the tree below Roughing, click on Entry Motion, and that the box is Off.  
f. In the tree below Cut Parameters, click on Finishing, and uncheck the box for Finish.  We will not need to do a finishing path for digits this narrow, relative to our tool diameter.
R.) In the tree in the 2-D Toolpaths – Pocket window, click on Linking Parameters
a. In the yellow box next to Depth, set the depth of cut as necessary, remembering that it should be a negative value.  (In this case, the depth should still be – 0.05)

b. Click on the green check button – that is all for this operation.

S.) On the operations tree, highlight the Toolpath Group, then …

T.) Click on the Verify button while that is highlighted.  Position the verify window that pops up, and:

a. Click on the View Tab and click on the Isometric button
b. In the simulation window, adjust the slider for speed to about 1/4 and

c. Click on the Play triangle and verify the operation removes the remaining corner material.

d. Follow your instructor’s directions if the operation is not correct.

U.) Minimize the verify window and return to the operations tree on the far left side.

V.) Return to the SolidWorks top toolbar, and click File > Save.
Drill the Holes of the Clock Face

A.) Right click on the box to the right of the Insertion Point > Mill Paths > Drill
B.) The Point Manager window pops up.  

a. Use your mouse to select the edge of the eight small holes of the clock face.  Order of motion can become important in the operation timing.  This can always be changed, later.

b. Click the green check button

C.) The 2-D Toolpaths – Drill/Circles Simple drill – no peck window pops up on the screen.  In the tree on the left of this window, click on Tool
a. Click on the Select Library Tool button

b. Select tool
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(not a drill, but close enough)
c. Click on the green check button.  This will select the tool and calculate the correct cutting parameters for the material and tool selection.

D.) In the tree in the 2-D Toolpaths – Drill/Circles Simple drill – no peck window, click on Linking Parameters
a. In the yellow box next to Depth, set the depth of cut as necessary, remembering that it should be a negative value.  (In this case, the depth should be – 0.15)

b. Click on the green check button – that is all for this operation.

E.) Return to the planning tree, and right click on the box to the right of the Insertion Point > Mill Paths > Drill
F.) The Point Manager window pops up, as before.  

a. Use your mouse to select the three edge segments of the clock face center hole.

b. Click the green check button

G.) The 2-D Toolpaths – Drill/Circles Simple drill – no peck window pops up on the screen.  

a. In the center, top window, click on the Circle Mill icon.  We do not have a tool with the exact diameter for this hole, but we can still make the hole by using a slightly smaller end mill and milling around in a spiral.  The name of the window changes to 2-D Toolpaths – Circle Mill
b. In the tree on the left of this window, click on Tool
c. Click on the Select Library Tool button

d. Select tool
3
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(didn’t we use this before?)
e. Click on the green check button.  

H.) In the tree in the 2-D Toolpaths – Circle Mill window, click on Cut Parameters
a. In the window, verify the Compensation Direction, and change as necessary – the goal is to cut inside the edges of the hole

b. Also in the window, make sure the box for Stock to leave on walls is set to 0.0
c. And make sure the box for Stock to leave on floors is set to 0.0
I.) In the tree in the 2-D Toolpaths – Circle Mill window, click on Linking Parameters
a. In the yellow box next to Depth, set the depth of cut as necessary, remembering that it should be a negative value.  (In this case, the depth should be – 0.75)

b. Click on the green check button – that is all for this operation.

J.) On the operations tree, highlight the Toolpath Group, then …

K.) Click on the Verify button while that is highlighted.  Position the verify window that pops up, and:

a. Click on the View Tab and click on the Isometric button
b. In the simulation window, verify the slider for speed is at about 1/4 from Slow to Fast and

c. Click on the Play triangle and verify the operation removes the remaining corner material.

d. Follow your instructor’s directions if the operation is not correct.

L.) Minimize the verify window and return to the operations tree on the far left side.

M.) Return to the SolidWorks top toolbar, and click File > Save.
Generate the NC Code and Edit the File

MasterCAM will generate most of the code for us, but we will need to edit the code to make sure that it works for our mill, and in a more time-efficient manner.  Specifically we will find and remove the following:

· The entire second to last line (the lines starts with a G28 – this code just wastes time)

· G43 & Hx (all of them – this would be the height offset compensation for a tool)

· G28 (except the last one – having these earlier than this just wastes time before tool changes on our mill)

· A0. (all of them – we don’t have an A axis on our mill)

Follow the steps (below) to produce the CNC code for your product:

A.) Return to the planning tree window, and 
a. Highlight the Toolpath Group (so that we generate G-code for all the operations)

b. Click on the Post (G-Code) Button – this is the button with the G1 symbol near the middle, right at the top of the planning tree window
B.) The Post processing window pops up.  Select the green check button
C.) The SolidWorks Save As window pops up

a. Use your mouse to scroll down I the left side window and select the Desktop option, then
b. Highlight your team’s Lab folder

c. Next to File name, append your first initial and last name to the Clock Front filename

d. Click the green check button

D.) The Code Expert window pops up on the screen.
a. Use the slider at the right to move to the last line of the code, and note how many lines have been generated for you.

E.)   In the code window: 
a. Click just to the right of the grey A0. code on the second to last line of code, then swipe left to highlight the entire line of code, and press the Back Space key on your keyboard
b. Highlight and delete only the red Z0. code just to the right of the G28 and before the M30 line of code. (This code would have left the tool on top of the workpiece at the end of the program, keeping us from removing it from the fixture!)
F.)   In the Find and Replace window to the right of the code window pane: 

a. Click in the Find What box and enter the code G43 

b. Click on the Find Next button.  The computer will highlight the next occurrence of G43 in the code window.

c. In the code window, highlight both the G43 and the Hx (x is whatever number follows the H code).  G43 is an offset for the height of our tool and Hx would be the associated length. On our mill, the built-in software takes care of that for us.

d. Repeat steps F.b. and F.c. until there are no more occurrences to find.

G.)   In the Find and Replace window to the right of the code window pane: 

a. Click in the Find What box and enter the code G28 

b. Click on the Find Next button.  The computer will highlight the next occurrence of G28 in the code window.

c. In the code window, highlight only the G28   For some mills, this would automatically raise the spindle  to change the tool.  On our mill, the built-in software takes care of that for us as part of an M06 command.

d. Repeat steps G.b. and G.c. until there is only the G28 on the second to last line of code left.  We will keep this one to make sure that we leave the mill in the best situation for the next program to run.
H.)   In the Find and Replace window to the right of the code window pane: 

a. Click on the Quick Replace button.

b. Click in the Find What box and enter the code A0. 

c. Click in the Replace With box, hit the Space Bar once and then hit Enter 

d. Click on the Replace All button.  The computer will remove all occurrences of A0. in the code window.  (A0. would rotate an axis that our mill does not have.)

I.) Save your NC code by clicking on the diskette icon on the top toolbar of the Editor.  Your code is now in your Lab folder for use on our mill.
J.) Copy your edited NC code file from your lab folder to the jump drive for your team.

Take the code to the CNC Milling Workstation for production.  After production, mark your initials on the side of your workpiece in pencil, then store your part in your team’s storage bin for future use.  Help your remaining team members to safely and correctly complete this lab, then 5S the laboratory before you leave.  There is no lab write-up required for this lab.
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